版权声明 - KCXP安装手册

版权声明

本手册版权为深圳市金证科技股份有限公司所有，未经本公司书面许可，任何公司、单位和个人不得以任何手段复制本书的全部或部分内容。

金证科技、KIINGDOM是金证公司的注册商标。

KCXP是金证公司的产品。

深圳市金证科技股份有限公司 版权所有


修订历史 - KCXP安装手册

修订历史

版本号 | 日期 | 状态 | 修订人 | 摘要
V1.0 | 2015-02-09 | C | 徐丹丹 | 初稿
V1.1 | 2015-05-14 | M | 徐丹丹 | 在安装步骤的第一步中增加说明哪些版本的KCXP需要安装VS2008运行库
V1.2 | 2016-06-15 | M | 徐丹丹 | 在“KCXP版本”章节说明10版本不比8版本高

状态标识：C – Created A - Added M - Modified D - Deleted


前言 - KCXP安装手册

前言


关于本手册 - KCXP安装手册

关于本手册

KCXP（Kingdom Communication eXchange Platform）是金证公司的通讯交换平台，本公司开发的所有业务系统均需要使用该产品进行通讯，本手册介绍如何进行KCXP（windows版）的安装。linux版、unix版、aix版、solaris版的KCXP安装与windows版有较大区别，但所有的配置文件均相同。除非特别说明，以下均指windows版KCXP。

对于非windows版的KCXP，按照KCXP目录下的readme文件进行操作后，使用kcxp start命令启动KCXP，无需安装。


名称解释 - KCXP安装手册

名称解释

KCXP（Kingdom Communication eXchange Platform）：金证通讯交换平台。

KCXP界面：显示和管理KCXP的界面程序，即kcxpmanager.exe。

XPCC：管理KCXP的命令程序。


技术支持 - KCXP安装手册

技术支持

如果您有任何关于本软件或文档方面的问题，请通过电话、传真、Email联系金证科技股份有限公司客户服务中心，亦可进入金证网站寻求支持信息。

电话： 0755-83172999

传真：0755-82955667

Email：jzservice@mail.szkingdom.com

公司网站：http://www.szkingdom.com


1. 系统配置要求 - KCXP安装手册

1. 系统配置要求

KCXP使用时对相关软、硬件环境的要求

操作系统要求：Windows2003 SP2 及以上版本。对于不同位数的操作系统，请使用与操作系统位数相同的KCXP，不建议在高位操作系统上运行低位的KCXP；

硬件要求：内存1G及以上，网卡100兆及以上，硬盘10G及以上。


2. 产品安装指导 - KCXP安装手册

2. 产品安装指导


2.1 安装前准备 - KCXP安装手册

2.1 安装前准备

使用 Administrator 登录机器，并确保机器当前未运行KCXP（“windows任务管理器”—“进程”确认kcxpsvc.exe和kcxpmanager.exe进程是否存在。若存在，点击右键选择结束进程）。


2.2 安装步骤 - KCXP安装手册

2.2 安装步骤

第一步：将KCXP发布包解压到指定目录，若目录中含vcredist_x86.exe（64位的是vcredist_x64.exe）（适用于KCXP 8.8及以上版本、10.11及以上版本），则双击，根据提示完成VS2008运行库的安装。

第二步：双击kcxpmanager.exe，将弹出KCXP界面，如下图1所示：

图1 KCXP界面

第三步：若机器当前未安装KCXP服务，KCXP界面工具栏“安装KCXP服务”按钮 [image] 是亮的，如下图2所示。操作则跳至第四步；

图2未安装KCXP服务

若机器已经安装过KCXP，如下图3所示，“卸载KCXP服务”按钮是亮的。则点击界面“卸载KCXP服务”按钮 [image] ，弹出提示对话框（下图4），点击“是”按钮进行卸载。

图3已安装KCXP服务

图4 卸载KCXP服务

第四步：点击KCXP界面工具栏“自动配置”按钮 [image] （或者点击KCXP界面的“系统”—“KCXP配置向导”—“自动完成”，如下图5），将弹出对话框，点击“是”按钮进行确认。

图5 自动配置

第五步：点击KCXP界面的“安装KCXP服务”按钮 [image] ，完成KCXP安装。


2.3 安装后检查 - KCXP安装手册

2.3 安装后检查

KCXP服务安装后，确认KCXP服务路径是否需要运行的KCXP路径，到windows的服务中去查看KCXP服务的路径。

方法一：“控制面板”中，双击“管理工具”，然后再双击“服务”。

方法二：在cmd中输入services.msc，回车。

都弹出windows服务的界面，找到“Kingdom Communication eXchange Platform”的服务”，如下图6所示：

图6 windows服务界面

双击查看其路径，如下图7所示：

图7 KCXP服务路径

若图7中显示路径不是需要运行的KCXP路径，则从2.1章节“安装前准备”开始，重新进行KCXP安装。


2.4 启动KCXP - KCXP安装手册

2.4 启动KCXP

在安装并确认KCXP服务路径后，点击KCXP界面工具栏的“启动KCXP服务”按钮 [image] ，即可启动KCXP。

kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本），用户可以在KCXP界面的“事件”窗口查看KCXP启动日志：蓝色为信息日志，红色为错误日志，橙色为告警日志。不能在KCXP界面“事件”窗口查看日志的版本，可到kcxp运行目录的日志文件夹查看日志（按日期分的文件夹）。

图8 KCXP启动日志

【注意】有些错误日志和告警日志不代表KCXP启动失败，可能某些功能或模块无法启动，但不影响KCXP的正常使用。用户根据经验自己判断，若无法判断，可联系金证公司。


2.5 关闭KCXP - KCXP安装手册

2.5 关闭KCXP

关闭步骤：

第一步：停止KCXP服务。

点击KCXP界面工具栏的“停止KCXP服务”按钮 [image] ，将弹出对话框，点击“是”按钮进行确认并等待“启动KCXP服务”按钮变亮。

第二步：关闭KCXP界面。

点击KCXP界面的“系统”—“退出”。如下图9：

图9 退出

【注意】实际生产环境，用户可以每周或每月进行一次KCXP的停止再启动（即重启）过程。


2.6 KCXP版本 - KCXP安装手册

2.6 KCXP版本

通过以下两种方式可以查看当前KCXP及kcxpmanager的版本信息，

方法一：点击KCXP界面菜单栏“帮助(H)”—“关于kcxpmanager”

方法二：点击KCXP界面工具栏的问号

都将弹出KCXP及kcxpmanager的版本信息，如下图10所示：

图10 版本信息

说明KCXP的版本号是10.12，大版本号是10版本，编译时间为2014年4月28日。

注：KCXP的大版本有两个：10和8，它们没有版本高低之分，只有在大版本号一样的情况下，才能比较版本高低（即10.1版本比10.0版本高，但不比8.8版本高），所以本文档说到适用版本时，会两个大版本同时说明。


2.7 KCXP授权 - KCXP安装手册

2.7 KCXP授权

查看KCXP版本，若如下图11显示：

图11 需要授权的KCXP

出现“尚未注册”字样，说明该版本的KCXP需要进行授权后才能使用，需要按照其提示，把该界面[]内的序列号发送给金证公司索取授权号。


2.8 checklist - KCXP安装手册

2.8 checklist

KCXP安装后，启动KCXP前请按照下表进行确认：

序号 | checklist | 备注
1 | 确保使用Administrator用户登录windows机器 | 一定要Administrator，而非其他有Administrator权限的用户
2 | 确保KCXP服务路径是要使用的KCXP路径 | 参考2.3章节安装后检查。如果不是，请从“安装前准备”重新开始安装
3 | 若KCXP运行目录中含vcredist_x86.exe（64位的是vcredist_x64.exe），确保运行了该程序 | 没有vcredist_x86.exe（64位的是vcredist_x64.exe），则无需安装
4 | 未授权的KCXP版本，需要索取授权号 | 有关授权参考2.7章节


3. 附录 - KCXP安装手册

3. 附录


3.1 常见问题解答 - KCXP安装手册

3.1 常见问题解答

1、 双击kcxpmanager.exe无法启动KCXP界面

答：确认是否在32位机器上运行64位KCXP。

2、 点击“安装KCXP服务”无法进行KCXP的安装

3、 机器没有安装KCXP服务，可是KCXP界面的“安装KCXP服务”按钮是灰的

答：确保使用administrator用户登录该机器，而不是其他有administrator权限的用户。

4、 点击“启动KCXP服务”无法启动KCXP（或是点击了“启动KCXP服务”按钮，立马又变灰）

答：请按照下列步骤一步步的进行确认

1） 确认使用administrator用户登录该机器，而不是其他有administrator权限的用户；

2） 如果是需要安装vs2008运行库的KCXP，确认已安装；

3） 按照2.7章节查看该KCXP是否授权；

4） 确认KCXP服务的路径下有kcxpsvc.exe文件。如果没有，关闭KCXP界面，并使用KCXP发布包按照KCXP安装步骤进行安装；

5） 确认KCXP服务的路径是正确的。如果不对，关闭KCXP界面，按照KCXP安装步骤进行安装；

6） 确认kcxp.ini中，各ip和路径配置正确。可以自己手动改kcxp.ini文件，也可在KCXP界面配置（可点击“手动配置”按钮自己配置或点击“自动配置”按钮）；

7） 查看KCXP日志，根据错误日志排查原因。

5、 把机器中原来的KCXP服务卸载了，重新安装了另外一个路径下的KCXP服务，可是启动后，发现运行的还是原来路径下的KCXP

答：停止原KCXP服务后，把KCXP界面也关闭了（确认任务管理器中kcxpsvc.exe和kcxpmanager.exe进程未运行），然后按照KCXP安装步骤进行安装（简洁步骤：确认kcxpsvc.exe和kcxpmanager.exe进程未运行—打开需要路径下的KCXP界面—卸载服务—自动配置—安装服务）。

6、 点击“卸载KCXP服务”后，“卸载KCXP服务”按钮变灰，但是在windows服务中仍能看到KCXP服务，导致点击“安装KCXP服务”无法成功

7、 点击“卸载KCXP服务”（或多次安装、卸载）后，“卸载KCXP服务”按钮未变灰，并且在windows服务中KCXP服务的启动类型为“禁用”

答：这种情况极少出现，是卸载KCXP服务时访问windows服务出了问题，重启机器即可。


3.2 KCXP文件（夹）说明 - KCXP安装手册

3.2 KCXP文件（夹）说明

在发布的KCXP目录下，含有一系列的文件和文件夹，以下简单说明。

文件（夹）名 |  |  | 说明 | 备注
kcxpsvc.exe |  |  | KCXP主程序 |
kcxpmanager.exe |  |  | KCXP界面程序，显示和管理KCXP主程序 |
xpcc.exe |  |  | 管理KCXP的命令程序 | 点击KCXP界面工具栏的小黑框可打开该程序
vcredist_x86.exe |  |  | vs2008运行库的安装程序（64位的是vcredist_x64.exe） | 对于不需要使用该安装程序的版本，其目录下不会有该文件
kcxp.ini |  |  | KCXP主程序的基本配置文件 |
kcxpmanager.ini |  |  | kcxpmanager.exe的配置文件 |
kcxpcli.ini |  |  | xpcc.exe的配置文件 |
exit.ini |  |  | 转发插件transmit.dll的配置文件 | 不使用transmit.dll，可以不用该文件
DLLFuncInfo.dat |  |  | 每个xpcc命令对应不同插件的不同函数的描述文件 |
kcxpexit.dat |  |  | 内部插件文件 | 删除该文件，就删除了该KCXP的所有内部插件。适用于kcxp_v8.8以下版本、kcxp_v10.11以下版本
kcxpmqm.dat |  |  | 队列管理器文件 |
kcxpplugin.dat |  |  | 加密压缩插件文件 |
kcxpqueue.dat |  |  | 应用队列文件 | 删掉该文件，就删除了该KCXP的所有应用队列
kcxprdef.dat |  |  | 远程定义（也叫远程队列、远程映射）文件 | 删除该文件，就删除了该KCXP的所有远程定义
kcxproute.dat |  |  | 路由文件 | 删除该文件，就删除了该KCXP的所有路由
kcxpuser.dat |  |  | 用户文件 |
operator.dat |  |  | 操作员文件 |
BpProtocol.dll |  |  | bp协议插件 | 在kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）中才需要
KCBPPacketOpApi.dll |  |  | 解析bp协议的插件 | BpProtocol.dll、KcxpMakBpAnsPack.dll和ExitOnXML.dll需要
KcxpMakBpAnsPack.dll |  |  | 组KCBP错误应答包的插件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）并且使用KESB路由转发或流量控制等功能时才需要
kcxpsharedmem.dll |  |  | 与客户端程序进程间通讯的插件 | kcxp_R才需要
kdutil.dll |  |  | 授权插件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）才需要
kmmlog.dll |  |  | 写日志插件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）才需要
kmmmib.dll |  |  | mib插件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）才需要
Krdp_v100.dll |  |  | 组播通讯插件 | kcxp_R才需要
libeay32.dll、SSLeay32.dll |  |  | 支持OpenSSL的插件 |
mmsConfMan.dll |  |  | 与mmagent通讯的插件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）并且使用kcmm监控或kesb才需要
mmsKcxpManager.dll |  |  | 处理mmagent关于kcmm命令的插件 | 在kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）中并且使用kcmm监控才需要
mmsKcxpManager_kesb.dll |  |  | 处理mmagent关于kesb命令的插件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）并且使用kesb才需要，用该文件替换mmsKcxpManager.dll
ParserExpr.dll |  |  | 解析表达式的插件 | ExitOnXML.dll及BpTransmit.dll、流量控制等功能时才需要
pcre.dll |  |  | 正则表达式库 | kcxp_R才需要
stlport.5.2.dll |  |  | STL库 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）才需要
XPCCCmdErr.lst |  |  | XPCC的错误码定义 |
client.pem、kcxproute.pem、server.pem |  |  | OpenSSL的证书 | 使用OpenSSL时才需要
BpProtocol.xml |  |  | 定义bp协议中字段名的文件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本），在KCXP界面填写消息路由规则和流量控制时需要用到
kcxpconnctrl.xml |  |  | 接入控制的配置文件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）使用接入控制功能才需要
kcxpexit.xml |  |  | 内部插件以及BpTransmit.dll的配置文件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）才需要
kcxpflowctrl.xml |  |  | 流量控制插件以及BpFlowCtrl.dll的配置文件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）使用流量控制功能才需要
KcxpParam.xml |  |  | 定义KCXP字段名的文件 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本），在KCXP界面填写消息路由规则和流量控制时需要用到
kcxperrdef.txt |  |  | KCXP界面对KCXP错误的相关定义 | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本），在KCXP界面进行错误码过滤时需要
.\api |  |  | 用户编写KCXP的客户端应用程序所需动态库和配置文件 |
.\doc |  |  | KCXP的文档帮助文件 |
.\exit |  |  | KCXP的内置插件、接入控制、流量控制等插件 |
.\exit | BpFlowCtrl.dll | 流量控制插件 |  | kcxp_v8.8（或更高版本）、kcxp_v10.11（或更高版本）才能使用
 | BpTransmit.dll | 新版路由转发插件
 | ConnCtrl.dll | 接入控制插件
 | FlowCtrl.dll | 管理流量控制的插件
 | transmit.dll | 老版路由转发插件 |  | kcxp_v8.8以下版本、kcxp_v10.11以下版本才能使用
.\log |  |  | 日志文件的存放目录 |
.\memhq |  |  | memory行情 |
.\persit |  |  | 可靠消息的存放目录 |
.\plugins |  |  | 加解密以及压缩、解压缩的插件 |
.\Timer |  |  | 定时消息的存放目录 |
.\xpccdll |  |  | xpcc命令对应的处理插件 |
.\实验程序 |  |  | KCXP的测试程序kcxptest.exe以及它所需要的运行环境 |